Deploy raw Kubernetes YAML does not deploy any resource from package

Octopus Version: v2023.1 Build 9767

I have a runbook with single step of type " Deploy raw Kubernetes YAML".
The step is configured to run directly on worker in kubernetes worker pool.
The step takes NuGet package and deploys all resources in YAML files.

The problem I’m facing is no kubernetes resource is deployed to cluster.

In deployment log I can see that extracted file is taken into variables substitution process :white_check_mark:

Performing variable substitution on '/etc/octopus/Work/20230403145436-1279455-15190/grafana/GrafanaDashboard.yaml'

Structure of my NuGet package is like:

|   BC.CIL.Telemetry.nuspec
|   [Content_Types].xml
|       GrafanaDashboard.yaml
|   \---services
|       \---metadata
|           \---core-properties
|                   772dd48606794bb0a450f476ab8a9faf.psmdcp

Kubernetes YAML file name field is set to **/*.yaml

I’m not sure whether it’s a bug or I’m missusing the step in some way.

Hey Pawel,

I believe that the issue is that you will need to hardcode the location of that yaml explicitly in the Kubernetes YAML file name field, rather than use wildcards. Can you please try putting grafana/GrafanaDashboard.yaml and let me know if that works?


Hey Jeremy,

I tried with providing explicit path and it worked :tada:
In fact I started with this approach, but I guess I must have been selecting wrong package version in my previous runbook runs.
So yeah, the step is doing its job.

Thank you for your help.

This thread can be closed.


Hey Pawel,

You’re very welcome!

Thank you for letting me know you’re in a good state.

We’re here if you run into any other snags in the future. I hope you have a great rest of your week.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.