Deploy an IIS Website missing "Create or update an IIS Web Site and Application Pool"

Version: 3.8.2

On previous versions (I don´t know which exactly) there was this checkbox on “IIS Web Site” section, before “Web Site name” textbox (sample is attached).
On this version this option is missing and existing web sites don’t have bindings updated. The deployment log register that a new binding exists, by it is not added:

Comparing existing IIS bindings with configured bindings…
February 7th 2017 09:21:24 Info Found existing non-configured binding: http *:9100:
February 7th 2017 09:21:24 Info Existing IIS bindings do not match configured bindings.
February 7th 2017 09:21:24 Info Clearing IIS bindings
February 7th 2017 09:21:24 Info Assigning binding: http *:80:xxxxxxxx
February 7th 2017 09:21:25 Info Assigning binding: http *:80:yyyyyyyy
February 7th 2017 09:21:25 Info Anonymous authentication enabled: True


Thanks for reaching out. At the current version of Octopus, by default the websites/app Pools will get updated with the new settings if they do not exist. So the checkbox doesn’t exist anymore because its already “checked”.

Now, you are saying that Octopus is detecting the 2 new bindings http *:80:xxxxxxxx & http *:80:yyyyyyyy but then its not adding them, leaving your websites bindingless? If this is the case, could you send me a screenshot of your bindings config in Octopus, along with a full deployment log following the below instructions?

1) Add these 2 variables to your project

2) Create a new release (so the new variables take effect) and deploy it. If possible skip as many steps as you can and only leave step we are troubleshooting in order to avoid the noise in the log.

3) Send us the raw log of that deployment


Hi Dalmiro.

It seems that I have made some confusion with releases vs process updates. I just test a new release where the new binding was present (for sure), removed this new binding on the target server and after the deploy it was add correctly.

Sorry for your time…
Ignore any attached files…

No worries! I’m glad to hear you are up and running :slight_smile: