Deploy a package step Getting failed for 1gb file

Hi Team,

I am trying to deploy a package on Linux server using listening tentacle and trying the option package will be downloaded directly from feed on target. I tried with 1.5mb and it deployed, but when trying with 1gb it is getting failed. Please let me know what would be the issue


Hey @prabhjotkour.91,

Thank you for contacting Octopus Support and sorry to hear you are struggling to download a 1GB file from your feed.

Most of the time this is down to timeout issues unfortunately, if you have chosen to download the package straight from the feed to the target you are essentially bypassing Octopus here, so it would be the connection from your Linux target to your Artifactory repository, which Octopus has no control over.

How long does that deployment run for before it fails?

Usually we suggest using the ‘download directly from feed on the target’ option if you want the deployment to run quicker as Octopus doesn’t need to download the package and send it to the tentacle, and you also want to take up less space on your Octopus Server as that package would then be cached on the server if you needed it for future use.

I do know I have issues uploading large files to Artifactory (cloud) but I don’t have any on mine that are over 200mb in order to test this.

One thing to check would be the space on your Linux tentacle, do you have enough space on there in order to save that 1GB file? Also, have you tried grabbing the file from the Linux tentacle directly from artifactory by using the artifactory download link from that file and does it download that way ie:

Ideally we need the full tentacle log from the Linux machine in order to see what the full error stack trace is but this will probably boil down to either lack of space on your Linux tentacle in order to store that 1GB file, or the deployment is timing out because its taking too long to download that 1GB file from your feed.

If we can get the tentacle log please from that target we may be able to direct you further, I have created you a secure link here for you to upload that log to, let us know once it has been uploaded and we can take a closer look.

Do check the space on your Linux tentacle and try downloading it directly from Artifactory though first as that will rule out Octopus being the issue and you wont have to send us the logs.

I look forward to hearing from you,
Kind Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.