Deploy 3 and Https service not starting

I have installed Octopus Deploy on a windows server 2012 R2 and everything look fine.

However when i try to enable https for the server i cannot get the service to run. The log shows the following:
System.Exception: The HTTP server could not start because namespace reservations have not been made. Ensure that the current user has access to listen on these prefixes by running the following command(s):
netsh http add urlacl url=http://+:82/ user=AST\webapp
netsh http add urlacl url=https://+:9004/ user=AST\webapp

at Octopus.Server.Web.WebServerInitializer.Start() in Y:\work\refs\heads\master\source\Octopus.Server\Web\WebServerInitializer.cs:line 52
at Octopus.Server.OctopusServerEngine.Start() in Y:\work\refs\heads\master\source\Octopus.Server\OctopusServerEngine.cs:line 48
at Octopus.Server.Commands.RunCommand.Start() in Y:\work\refs\heads\master\source\Octopus.Server\Commands\RunCommand.cs:line 37
at Octopus.Shared.Startup.AbstractCommand.Octopus.Shared.Startup.ICommand.Start(String[] commandLineArguments, ICommandRuntime commandRuntime, OptionSet commonOptions) in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\AbstractCommand.cs:line 58
at Octopus.Shared.Startup.WindowsServiceHost.<>c__DisplayClass1_0.b__0() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\WindowsServiceHost.cs:line 19
at Octopus.Shared.Startup.WindowsServiceAdapter.RunService() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\WindowsServiceAdapter.cs:line 44

So i run the netsh command and get the following when i run ‘netsh http show urlacl’:
Reserved URL : http://+:82/
User: AST\webapp
Listen: Yes
Delegate: No
SDDL: D:(A;;GX;;;S-1-5-21-1804298267-1058948339-1586563796-19331)

Reserved URL            : https://+:9004/ 
    User: AST\webapp
        Listen: Yes
        Delegate: No
        SDDL: D:(A;;GX;;;S-1-5-21-1804298267-1058948339-1586563796-19331) 

I from this assume that the reservations are ok.

But the services will not start.
Can anyone help?

Hi Stephen,

Thanks for getting in touch! The first thing to check is to ensure that there isn’t another process using that port.

Open a command prompt and run the following command.
netstat -aon | find /i "9004

If it shows any results, then it indicate that another process is using the port. The next step is to find the details of the process and reconfigure it or kill it. Run the following command to displays the process details. Substitute the appropriate process id for PROCESS_ID.
tasklist /FI "PID eq PROCESS_ID"

If netstat didn’t show anything, run the following command to check if your SSL cert is mapped appropriately.
netsh http show sslcert

If the certificate mapping is incorrect or missing, I’d recommend removing and then re-adding the binding.

Finally, I’d recommend scanning your Octopus server log to see if there are any additional errors.

Let me know how you go.