Custom polling port not being used on tentacle

usability
known
(Joshs) #1

I’m trying to change the polling port to be port 80 so I don’t have to deal with corporate firewall requests.

I changed the server bindings to only be on https://server:443
image

and the configuration Octopus.Communications.ServicesPort to 80 (and restarted the service)
image

But, when it goes to run the tentacle install, it still uses the default/old port 10943 and fails.
image

So — what’s the proper steps to install tentacles that will use port 80 for polling now?

(Paul Calvert) #3

Hi @joshs1,

Thanks for getting in touch!

For a new tentacle the easiest way to do this would be to hit the Show script option and copy that out to Powershell. You can then amend the port within the script and use that to configure any targets needed.

If you need to amend a tentacle that has already been configured, you can use server comms command on tentacle.exe to amend this.

I hope this helps, please let me know if you have any further questions.

Regards,
Paul