Custom Install Directory not working

I’m setting up Octopus for the first time, and I’m having trouble getting the Custom Install Directory feature on the NuGet Package step to work. I set it to D:\mypath, but it installs to the default location C:\Octopus\Applications. Here’s the log statement:

The package has been installed to: C:\Octopus\Applications[my application name]\1.0.9_6
10:32:35 Verbose | If you would like the package to be installed to an alternative location, please specify the variable ‘Octopus.Action.Package.CustomInstallationDirectory’

I have the NuGet step configured with the Custom Install Directory, and I’ve tried specifying “Octopus.Action.Package.CustomInstallationDirectory” on the project variables, to no avail. I’ve also tried restarting the server and the tentacle.

I’m probably missing something, since this is my first Octopus project. Any ideas?

Hi Adrain,

Have you tried creating a new release after changing the setting? Project variables are snap-shotted when a release is created, so new releases must be created when making updates.

Hope this helps,

Yes! Thanks, that took care of it. I’ll have to keep that in mind in my future use of Octopus. With a document database in play, it’s easy to make a snapshot of data and run with it!