Creating new release only shows latest 20 versions of NuGet feed

We upgraded yesterday to version 2 (and again today to, and are having problems creating new releases. In our previous version (, when we browsed the available package versions, we had a long list available so could select any previous version to deploy. With the latest version, this list is capped at 20, so we can’t create new releases for packages from branches on older version numbers.
I can’t find any settings anywhere to change this, is there a way I can work around this to increase the number of package versions available to select from? Love the interface changes in version 2 by the way, the variable management is so much better now!
Thanks, Simon.

Hi Simon,

When creating a deployment, you can simply type in the package version (choosing “Specific Version”) - does that work for your scenario?


Hi Nick - That might work if we can be confident it will deploy that particular NuGet package, in the past we have been able to select this from the Search drop-down so we know we are getting the correct package. I’ll try this when we next deploy one of the older releases.
Incidentally, in one of the much older versions, when we did select a particular NuGet package release, it automatically updated the Release Version field at the top of the screen to match the package you selected from the search function. At some point after one of the Octopus releases this stopped working. Do you know if there was a specific reason for this? Now we have to select the release from the search window, then manually update the new Release Version to match the package selected.
Cheers, Simon.

Thanks for the feedback on release number selection; there’s been a bit of churn around this trying to find the right general approach - we’re aiming to complete to address it soon.

Great, thanks for the info. Will update this discussion once we’ve tried manually entering the version in the specific package field.

We’re having this problem too, except it doesn’t appear to contain the latest 20 nuget packages, but what appears to be an arbitrary 20. If I rebuild a project in TeamCity I don’t see the new package as an option when I select the magnifying glass by specific version.

Hi Nick - Typing in the package version manually in the search box did indeed deploy the correct version, but I also agree with Doug above. The version we deployed today was freshly built (this was a dev build, but when looking in the search box, the 20 listed seem to be based on the latest version numbers, not the latest build dates. So all the ones displayed here show 1.1401.5.5, 1.1401.4.91 etc.
It is of course much nicer to select the package you want from a list rather than typing it in and possibly making a mistake, but for now we can continue to deploy successfully.

Thanks - I’ve added an issue to track this: