Copying files to Azure File share

I’m using Deploy a package template to copy files to azure file share.
using custom scripts(Powershell). i’m getting the error like Invalid drive specification

Hi Mahaveer,

Thank you for reaching out. To get a better understanding of what is happening here, we would need to get a full log from the deployment. This should have the error and what is happening around the time of the error, which will help us get to the bottom of your issue.

I have linked some great documentation below, to assist you with getting the logs.

Look forward to hearing from you.

Best Regards,

Hi Nael,

Thanks for your replying.
I was trying to copy my files from octopus server to tentacle. The folder to which i’m copying to tentacle is a shared folder and is in the azure machine.
I tried to execute the powershell script with xcopy, directly trying to copy the files over to the folder by specifying both the drive name and shared folder path. it didn’t work
I tried using azure powershell script template as well, even it didn’t work.
I have attached just two the error log. hope that help else i can provide few more logs.

Mahaveer (4 KB)

Hi Mahaveer,

Sorry I am not quite understanding what you are trying to accomplish. Is your Tentacle on a VM in Azure? And you are trying to copy files to another Azure VM?
Could you explain your environment and what you are trying to accomplish and I might be able to guide you on the best way to set that up in Octopus.