Clean install, server cannot communicate with tentacles

Howdy Paul,

I am trying to get a clean install of Octopus running for an MVC project I am starting.

I grabbed the latest installers, installed the server on the deployment server and a tentacle on our test web server. Individually the installs seemed to have worked nicely, nothing out of the ordinary in the event logs or anything.

However I am currently trying to configure the test environment in octopus, and am having trouble trying to get the octopus server to communicate with the tentacle machine I have defined.

I have defined the url for the machine as http://myservername.domainname.local/10933/

I have attached a screenshot of the health check, along with the stack trace.

You’ll also notice the health checks are returning “Success!” even though their output contains exceptions.



201111111156OctopusException.txt (10 KB)

Hi Andrew,

A status of “Success” for a Health Check even though a server failed is to be expected - originally I thought it was sensible for the task to complete ‘successfully’ even though some servers weren’t available. I’m going to change that in a future release.

As far as the server goes, what happens if you put this in your web browser on the Octopus server?


If you remote into the test server, you can also check the Task Manager - you should find two instances of Tentacle.exe running (one is the service, the other is the child process it creates)


Hi Paul,

I’m having what I think is the same problem. Tentacle and Octopus both successfully installed, but Octopus unable to communicate with the Tentacle.

What’s interesting is that if I RDP into the Tentacle server I’m able to go to http://localhost:10933 and access the HealthService - however from any other computer on the network I can’t access it. No firewalls on the network, windows firewall disabled, so I can’t figure out what might be preventing the connection.

Doing a netstat -a shows that the tentacle is listening to, so we can rule out any issues with binding to the wrong NIC etc. Any ideas?

Many thanks

Hi Paul,

Believe it or not, I only turned off the windows firewall in the public profile :frowning: It all works now!


Hi Mattias,

Thanks for letting me know - good luck :slight_smile:



I know its old but I’m getting the same issue.
My situation is the same as Mattias and I tried to do what he did but not worked for me.

I don’t know how to proceed now.