Changing the Tentacle URL in the octopus worker using configuring Linux Tentacle script

Hello team, I’m automating the octopus worker installation using the listening worker for linux script that you shared here
Everything’s being installed correctly except for the Tentacle URL which is being set to
https://worker-hostname:10933/ instead of hostname ip address (something like, is there anything in the script that can be changed to make this happen?

Hi @Atefeh!

Thanks for reaching out, and for the great question!

This is certainly possible, using the --publicHostName switch in the register-with command. This will tell the Octopus server what the worker/tentacle’s connection hostname will be.

I hope this helps, and please let us know if you have any further questions!

Hey Justin,
Thank you for the prompt reply. Indeed it works. The only thing was I was creating a worker which uses the register-worker but still has that --publicHostName option. Works beautifully, thanks again!



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.