Change Package/Library Directory

I am trying to change the package/library directory (from C:\ which is filling up) to the data drive (D:\ which has plenty of space). I am using O.D. default built-in repository. I can’t seem to find a setting to change the storage location. How might I go about doing this?


Thanks for getting in touch! What version of Octopus are you using? The answer will be different for 2.6 vs 3.0



We are using version Does that help?

We are having issues where we are running out of space on C: due to the packages being stored (by default) on the C drive. We would like to move this to the data drive ( D: ). However we are a little shy about making uneducated guesses about how to do so. We use Jenkins and Octopus Deploy as in our continuous integration process and we don’t want to break that by introducing an OD configuration change that breaks our ability to push packages to the repository (and thereby break our CI process and our ability to deliver software with it).

Best Regards,


Hi Brandt,

It does help. Unfortunately the only version where you can define the package directory is 3.0.
It cannot be moved otherwise. You can setup a retention policy on the folder but it will depend if you use retention policies for your releases.

You could consider setting up your own Nuget.Server we suggest Nuget.Lucene and that can be in a different directory that you connect to with Octopus. The changes would not be major with either Jenkins or Octopus, as it should just relate to a new URL to push the packages to, and then creating a new external feed in OD.


In 3.x where is the setting?

The last question around how to change the setting for the location of the package files was not answered. Do you have an update?

I would like to be able to change just the Packages folder location (not the whole of the Octopus Home directory) as it provides flexibility for storage options.

Hi Lance,

In 3.x we have a setting you can use to change where Octopus looks for the internal repository package files: Octopus.Server.exe path --nugetRepository D:\\Packages
You will need to stop the service before running the command.

Hope that helps!