Chain Deployment - Not be able to deploy the latest release in a channel


I’m trying to implement this great step but i’m facing one issue, when it’s started with the deployment of my different projects it not takes the latest version of the Channel but it will take the last version.Within the step i’m leaving the release number empty (Leave blank to use the latest release in the channel) but it seems that the step will take the last version from the channel an not the latest version.

Could somebody look at this problem?

Kind regards,


Hi Geert,

Thanks for getting in touch! I’m sorry you’re hitting this unexpected behavior using the Chain Deployment step template. I’ve given it a test and I’ve confirmed that it will deploy the most recently created release instead of the latest release version of the project when the version isn’t specified in the step.

Releases are ordered from most recent to least recent, and it looks like the step is finding the first in this list with the following line.

$this.Release = Invoke-OctopusApi $this.Channel.Links.Releases | % Items | Select-Object -First 1

You can work around it by specifying the release version or ensuring the most recently created release is the latest release version in the channel. Additionally, you could modify the step template code and save a custom copy of it, or configure the step to create a new release of Project B, which the step in Project A will then deploy.

Feel free to also reach out to the developer directly in the comments of the library page.

Do any of these options help in your case? Let me know how you go and if you have any further questions!

Kind regards,


Hello Kenny,

Thanks for the reply. It’s a bug in the step template so I have reach out to the developer directly. This can be closed now!

Kind regards,