Certificate Selection

(Peter Banyard) #1

I’ve just been creating a couple of deploys that require a certificate. Adding the certificate into the library is no problem but when I need to select the certificate and add it as a Variable the list I am presented with does not allow scrolling to get to the certificate I require (we have about 20 Certificates stored in the library). The only way I managed to select the certificate I required was to zoom out as far as I could in the browser and then select the appropriate certificate. Surely a scroll bar or filter on name would make this feature a lot more useable. We will be adding more certificates and selecting any future certificates as variables is not going to be easy.

Using Version 2019.3.3

(Kenneth Bates) #3

Hi Peter,

Thanks for getting in touch! I’m sorry to hear you’re hitting this unexpected and annoying behavior. I haven’t been able to replicate this exactly, though I’m not positive I’m looking at precisely the same place you are here. Could you provide some screenshots showing this issue and where you’re hitting it?

I look forward to hearing back!

Best regards,

Kenny

(Peter Banyard) #4

Kenny

Please see attached document with screenshots and annotations explaining what I see. Let me know if you need any more information.

Cheers

Peter Banyard

http://www.computershare.com/disclaimer/emea

Octopus issue.pdf (279 KB)

(Kenneth Bates) #5

Hi Peter,

Thanks for following up and providing that additional information. I’ve been able to replicate this behavior in 2019.3.3 when using Firefox. However I was unsuccessful while using Chrome, and also when running 2019.6.3 in Firefox and Chrome. I couldn’t spot a fix for this issue specifically, so I suspect this was likely fixed in conjunction with another bug fix we shipped between these two versions.

Would you be able/willing to upgrade to 2019.6.4 LTS to see if that fixes the behavior for you? Alternatively, could you confirm if this behaves better for you in another browser?

I hope this helps, and please don’t hesitate to reach out if you have any further questions moving forward. :slight_smile:

Best regards,

Kenny

(Peter Banyard) #6

Kenny

Thanks for the information. Upgrading is out of my hands as this is a corporate instance, but I can use chrome so for the moment that looks like the way forward.

Thanks

Peter Banyard

http://www.computershare.com/disclaimer/emea

(Kenneth Bates) #7

Hi Peter,

Thanks for following up, and you’re quite welcome. Glad to hear that using Chrome for the meantime would help. Please don’t hesitate to reach out if you have any questions or concerns in the future!

Best regards,

Kenny

(james.hough) #8

Hi.

We are experiencing the same problem - even when using the Chrome browser. I have also tried Edge and Firefox. We are running 2019.3.8 (LTS)

We cannot upgrade to a newer version because our organisation is licensed for this LTS version.

We are able to select a certificate by modifying the HTML (details below) or zooming out (about 25% zoom for us - but that makes it difficult to click the right item). If we add new certificates we won’t be able to do this at all anymore.

Could you please investigate this issue on the LTS version?

Many thanks.

Other users affected by this might also like to know that if you use Browser Dev Tools, inspect the HTML element, and find the container DIV, you can add an inline style=“height:600px” which will introduce a scrollbar. This is easier to work with the scrollbar than it is to zoom the page.

Edit: 2019-10-04
We upgraded. ¯_(ツ)_/¯

(system) closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.