Can't deploy to Azure, how would I find the root cause?


Using Octopus 3.3-beta002.

When I’m trying to add an Azure account, the “Verifying account” section just shows “An error occurred while sending the request.”.
Consequently, I can’t add the Azure account to the “Web App” step, where it just shows "No connection could be made because the target machine actively refused it ".

How would I find the root cause to this? (e.g., is it a Proxy issue? A Firewall issue? An issue with the SSL Cert? It’s an internal network, so it could be a whole bunch of things and I don’t just want to randomly try out things, although that’s what I’m doing anyway. Is there a verbose output that tells where where/how Octopus tries to connect?)

I enabled System.Net tracing and I think it might be a SSL Certificate problem. Is there a way to set ServicePointManager.ServerCertificateValidationCallback in Octopus so that I can test that theory?

Hi Michael,

Thanks for getting in touch! We don’t do anything fancy, but also won’t be able to get much logging from Octopus. To trace this our thoughts would be to run the same simple commands that we do when testing the account settings.

the different account types use different calls but they are below. You should be able to run these from the Octopus server using PowerShell and hopefully it will give more meaningful errors or a chance to trace where the problem is occurring.

Service Manangement Certificate Account

Import-Module Azure


Service Principal Account


Hope that helps!

Thanks! PowerShell works fine, Get-AzureWebsite returns a list of websites.

If I change the OctopusService to run as myself instead of “Local System”, it works. So now I think it’s a Proxy issue. I’ve set Octopus to use the IE Proxy, but I don’t know if that setting is system-wide. I’ve ran netsh winhttp import proxy source=ie, which now lists the proxy, but still no success.

Is there a different way to configure the proxy somewhere in Octopus?

Hi Michael,

When you say ‘I’ve set Octopus to use the IE Proxy’ do you mean through the Octopus Manager as that is the way to configure the proxy somewhere in Octopus.


Yes, through Octopus Manager. I’ve upgraded to Octopus 3.3.1 as well.

Hi Michael,

Id suggest that if you didn’t have to change the proxy settings to get it working as your user, it won’t help with Local System. It sounds like an environmental permission. There is no where else to change proxy settings for Octopus.
You create a user for Octopus to run under and compare its permissions to what yours are knowing that they do work. This may be your next step.