Cant add tentacle, it prompts to 'please paste...' even though it's been pasted

Good afternoon,

I’m trying to install Octopus for a small project I’m working in an attempt to automate deployments. I’ve installed Octopus Server on a fresh Server 2012 r2 virtual machine successfully, the machine I’m wishing to deploy to is an Amazon ec2 Server 2008 AMI. When the tentacle configuration wizard prompts for the thumbprint, I copy it directly from my virtual machine and paste it into the thumbprint field of the tentacle wizard; as soon as I click Next it prompts me “Please paste your Octopus Server certificate thumbprint” as if it isn’t recognizing the paste. I’ve tried pasting it into a text file and then putting it onto the ec2 and copying from that source as a long shot it could be somehow my paste command.

I’m spinning up a new server 2012 ec2 instance now to see if somehow it’s the different os’s conflicting with key generation / recognition.

Any help would be appreciated, I haven’t found anyone else with this issue so I’m perplexed.


Server 2012 worked! I must have missed that in the docs the os’s must match. Thanks for the amazing deployment tool, I’ve used it before with great success :slight_smile:

Hi Nicholas,

Thanks for getting in touch!
We do not force the Octopus Server and Tentacle to have the same OS, for majority of our customers this would bring their deployments to a grinding halt if it was the case.
We actually have a slight suspicion that there might have been some whitespace like a space or newline or some other invisible character at the end of your copy and pasting and that would have been stopping the configuration. Which is a nice bug you have potentially found.
I have created a GitHub issue to do a few tests and track down if this is the case and fix the bug.

Sorry for any inconvenience this may have caused you.