Cannot upgrade to Azure DevOps task 'Create Octopus Release' version 4.*

usability
(RB) #1

Hello,

We use Octopus on premise and Azure DevOps for our build pipelines.

The Azure DevOps does not know about Octopus configuration. So I cannot set the values in the screenshot.

The space variable states: “The space within Octopus. You can leave this blank to use the default space. (Octopus Deploy 2019.1+)” I cannot leave it blank, because it says “This setting is required”.

We use Octopus v2019.6.6.

How can we upgrade our Azure DevOps pipelines to use version “Create Octopus Release” version 4.*

Thanks in advance

(Kenneth Bates) #3

Hi @RB,

Thanks for getting in touch! I’m sorry to hear you’ve hit this confusing issue. The space name (e.g. Default) needs to be typed into this field (or selected from the dropdown). Allowing this field to be blank made it too hard for the dependent dropdowns to query the correct space, so it looks like a bug in the help text which we’ll get fixed up shortly.

Does specifying the space in this field get your releases created as expected?

If you’re not seeing anything displayed in the dropdown, you may need to check that your service connection to Octopus is correctly configured (including fixing any SSL errors or ticking the ignore option), and that your network is allowing connections from Azure DevOps to Octopus.

I hope this helps get you going! Don’t hesitate to reach out if there’s anything else we can assist with. :slight_smile:

Best regards,

Kenny

(RB) #4

Hi @Kenneth_Bates,

We have put in the default name of our space (which was not the name “Default”). And it now works as expected.

We chose to not publicly make octopus available to the outside world. So our dropdowns are always empty. Therefore we have to fill in the fields manually, that’s no problem because we don’t alter or create build pipelines that often.

Thanks for your response.

(Kenneth Bates) #5

Hi @RB,

Thanks for following up, and that’s great to hear you’re up and running! Please don’t hesitate to reach out if you have any questions or concerns in the future. :slight_smile:

Best regards,

Kenny

(system) closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.