Cannot login to Octopus UI using local user

I have created a new local user but I am unable to login to the octopus UI using it. Only shows “invalid user or password”. Any idea why this is happening?

Octopus v2019.6.8

Hi @Sharjil,

Thanks for reaching out!

Can I ask a few questions, please, to get an idea of the issue?

How did you create the new user? Did you do this through the Octopus UI, or did you perform the user creation via command-line using Octopus.Server.Exe?

Does anything show up in the server logs after creating the user or after trying to log in that may point to the issue?

These can be found in C:/Octopus/Logs by default or home/Octopus/Logs.

If you’d like to send them over, I’ve created an upload link for you attached to the account you’re posting from: Support Files.

Let me know about the above, and I’ll do my best to help you further!

Kind Regards,

Hi Adam,

Thanks for taking this up. I tried to create the user from the UI.
Nothing shows up in the logs when I create the user but when I delete it, the logs get written in the log file. I have uploaded the same in the link you provided.
You will find the deletion logs at the very end of the log file. The user name is ‘per’.
After the deletion I tried creating it again, but same error on UI and nothing in the logs.

Let me know if you find anything.

Hi @Sharjil,

I am taking over for Adam on this one as he is currently away and I want to move this forward.

Thank you for getting back to us with those logs, I have looked through them and can’t see anything obvious, I can see the user being deleted at the end as you mentioned but not created.

I am going to try and reproduce this on my end with your Octopus Instance version and see what I get.

I will let you know how I get on.

Kind Regards,

Clare Martin

Afternoon @Sharjil,

I have not managed to replicate what you are seeing, however, there may be some other things to check if you are able to:

  • When you create the ‘per’ user are you making sure the user is active? I would also give the user a generic password to begin with like ‘Password1234’ (just to make sure there are no special characters causing issues).

  • You should be able to see it being created in the Octopus Instance logs if you tick the ‘Include System Events’ box in the Configuration - Audit section in Octopus. This should give you an idea of what is going on.

You are correct in that the Server logs (the ones you provided us) will only show you the deletion of an account and not the creation but the UI logs should be easier to look at anyway.

Let me know if implementing those suggestions has helped at all, if not we can dig into this a little further.

Kind Regards,

Clare Martin

Hi Clare,
Thanks for checking this. I could see the user creation logs in the Audit section. But still I am unable to login with that user, eventhough I have provided the most basic password for this ID.


Hi @Sharjil,

Thanks for getting back to me with that, I was wondering if you could just check something else for me. Are you able to go into Configuration - Settings and then click on Username and Password.

Are you able to check that is Enabled for me please? If it is disabled can you enable it and see if you can then log on with the ‘per’ account.

Hopefully, we can get you logging in with that account soon!

Kind Regards,

Clare Martin

Splendid! This did wonders :slight_smile:
Thank you so much. It was disabled.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.