Cannot log into Octopus Deploy with AD account

security

(Sven Schipper) #1

Hi,

Since june 1st we have a problem in my company that we cannot connect to Octopus using our AD accounts. When trying to log in it gives the error: “The specified domain either does not exist or could not be contacted.”. Several attempts have been made but no answer has been found yet.

The machine from which we use Octopus is a VM in Azure, where the machine itself is still connected to our AD.

We tried:

-Octopus has been updated to the latest version (2018.6.5).
-Tried to add the active directory container, this only caused Octopus to display the error “The specified domain either does not exist or could not be contacted.” twice.
-Running windows updates on the VM we run octopus on.
-Removing the Octopus VM from the AD and rejoining it.

I also created a secondary VM on which I also installed Octopus Deploy with a trial license in order to double check settings in there and perhaps try to replicate the problem. Octopus on this machine is still connected to the AD. I also verified that I used the correct Active Directory Container while checking this on the main Octopus VM.

I hope somebody here has experience with this problem and/or can give us some insight on how to solve this problem.
Thanks in advance!


(Nick Josevski) #2

Hello,

Thanks for getting in touch. From the sounds of it is connection related, either DNS or firewall, we recommend investigating that avenue first.

Perform an nslookup from the Octopus Server trying to reach the NT Domain, and see what results you get. Another important item to check is even though the server is on the domain, ensure the Octopus Deploy service is running as an active domain user account that hasn’t had the password expire. Sometimes an upgrade of Octopus can interfere/break that setup.

After that compare more differences between the primary server, and the test one that did work, to try and find what else may be misconfigured.

Regards,
Nick


(Nick Josevski) #3

Hello,

I just wanted to check in to see if you resolved the AD log in issues? We’re also curious as to what may have been the issue if you did work it out.

Regards,
Nick


(Sven Schipper) #4

Hello Nick,

Thanks for your reply, we did indeed eventually find the solution to our problem.
It turns out, our Octopus Server was configured to log in as “./OctopusServer” instead of “Local System”.
This went ok for a while, but it was configured by someone who is no longer working for the company. Because his company account became inactive, the connection Octopus had to the AD became inactive as well. Changing this back in the windows Services screen turned out to resolve the issue

Thanks for your help and for checking in with me again!

Regards,
Sven