Cannot create service user account

Trying to create service user account - says “The passwords do not match”

Octopus Deploy 3.5.1

Hi Nikolai,

Thanks for reaching out. In 3.5 now you need to give a password to your service account. It seems like you cannot see the new “Password” and “Confirm Password” fields because you browser is still using a chache version of the site. Could you try doing a hard refresh with Ctrl+F5 on that screen and see if the fields show up?


I tried to refresh it still the same, once I select This user is a service account then all other fields like email and password disappear.

And I am totally confused by your statement - “now you need to give a password to your service account” - for what reason service account need password?

Also below service account selection there is label :

“A service account can log in using API keys only. After creating the user you’ll need to add some API keys before the account can be used.”

Hi Nikolai,

Deep apologies for the misunderstanding on my side. This is totally a bug. Service accounts should definitely not request a password.

I’ve created a github issue to get this fixed:

While we fix that issue, you can create a Service account using Octoposh with this snippet:

Please let me know if you need help with anything else. And once again sorry for the initial misunderstanding!