Cancelled Task is Hanging


I upgraded my tentacles using Hydra to version 3.0 this worked fine. After installing the octopus server 3.2, it asked me to update the Calamari this was fine and worked a treat. Except two machines were not switched on, the upgrade Tentacles task has been running for two days trying to update the tentacles, I have hit cancel lots of times but that does nothing, i have also restarted the octopus server but that didn’t help either. How can I cancel this task?

Hi Marcello,

I’m sorry to hear your upgrade didn’t proceed completely smoothly.

I just need to clarify which task it is that is hanging. Do you mean the upgrade-calamari task on the 3.2 server, or the upgrade tentacles task on the old 2.6 server?


Hi Michael,

Thanks for getting back to me. The task is hanging on the 3.2 server.

I was very pleased overall with the upgrade process to be honest, was only this hanging task that has been an issue :slight_smile:




You can execute the following SQL against the Octopus Deploy SQL Server database:

UPDATE [dbo].[ServerTask] Set State='Canceled' WHERE Id='{Your Task ID}'

You should be able to get the task-ID by hovering your mouse over the Task on the Tasks page.

That will cancel your zombie task.

Have the two Tentacles that were offline now been upgraded?

Hi Michael,

thanks for the information, that worked straight away :slight_smile:

Everything so far seems to be upgraded and working as expected.

Cheers for the help.


You’re most welcome Marcello.

Happy Deployments!