Calamari tar.gz for linux not showing in predefined directory

At my work we use octopus deploy for most of our windows based services but so far the linux side have been unused and I had plans to fix that. I have tried to follow the guides and I see SSH is working(connetion fine, visudo is working and all…) I have installed the prerequirements on one of the dev servers but when it is supposed to upload Calamari it can’t find the file :frowning: C:/program files/octopus/… tar.gz (at home so I dont remember the location) and I can confirm that the file does not exist on the server.

What is the ‘best practice’ to use here? Download the git file and zip it, or is there some library or other location I can get the file from so it surely matches our Octopus Deploy version? Sorry for the stupid question I am new to Octopus Deploy and eager to get forward.


Hi, thanks for reaching out.

To help out here, I’ll need some more info. Can you share the Octopus server version, more details on the setup you have added and the raw log of the task that’s failing.

Calamari should come with Octopus server, so if it’s missing we’ll have to do some checking to see what’s wrong.


Hello Micahel thanks for quick response. Here is more information

Octopus version: 3.4.15 (as indicated by the web gui) in configuration -> licence I can see it is licenced.
I have my connection setup to go directly from my octopus deploy master(not those tentacle thingy’s)

The problem in this task, as I see it is, That file isn’t there(as a matter of fact no Calamari*tar.gz seems to be present.):

–> 16:43:15 Fatal | The step failed: Activity bashredirect on failed with error ‘Access to the path ‘C:\Program Files\Octopus Deploy\Octopus\Calamari.3.4.37.tar.gz’ is denied.’ <–

Task ID: ServerTasks-32010
Task status: Failed
Task queued: den 31 oktober 2017 16:43
Task started: den 31 oktober 2017 16:43
Task duration: 4 seconds
Server version: 3.4.15+Branch.master.Sha.338d6700fb9db1ea111b3c9869d4dfec526068e3

                | == Failed: Deploy moodlessh release 0.0.1 to Dev ==

16:43:12 Verbose | Guided failure is not enabled for this task
16:43:16 Fatal | The deployment failed because one or more steps failed. Please see the deployment log for details.
| == Failed: Step 1: bashredirect ==
16:43:15 Fatal | The step failed: Activity bashredirect on failed with error ‘Access to the path ‘C:\Program Files\Octopus Deploy\Octopus\Calamari.3.4.37.tar.gz’ is denied.’.
16:43:15 Verbose | bashredirect completed
| Failed:
16:43:12 Verbose | Octopus Server version: 3.4.15+Branch.master.Sha.338d6700fb9db1ea111b3c9869d4dfec526068e3
16:43:12 Info | Executing script on '’
16:43:12 Verbose | Requesting upload…
16:43:12 Verbose | Establishing SSH connection…
16:43:12 Verbose | SSH connection established
16:43:12 Verbose | Beginning streaming transfer of to $HOME.octopus\OctopusServer\Work\20171031154312-19
16:43:12 Verbose | Establishing SFTP connection…
16:43:12 Verbose | SSFTP connection established
16:43:13 Verbose | Stream transfer complete
16:43:13 Verbose | Requesting upload…
16:43:13 Verbose | Beginning streaming transfer of variables.json to $HOME.octopus\OctopusServer\Work\20171031154312-19
16:43:13 Verbose | Stream transfer complete
16:43:14 Verbose | Requesting upload…
16:43:14 Verbose | Beginning streaming transfer of to $HOME.octopus\OctopusServer\Work\20171031154312-19
16:43:14 Verbose | Stream transfer complete
16:43:15 Info | This server does not have version 3.4.37 of the Calamari package. It will be pushed automatically.
16:43:15 Verbose | Disposing SFTP connection…
16:43:15 Verbose | Disposing SSH connection…
16:43:15 Fatal | bashredirect on

Hi, thanks for getting back to me with the log.

Octopus server builds Calamari.3.4.37.tar.gz on demand and then transfers it to the ssh target, so it won’t be present until the server has successfully built it and pushed it the target.

In this case it’s failing to write to the directory. I expect that the account that’s running Octopus server doesn’t have write permissions to that directory. Looks like our docs page on server set up isn’t correct in this case. I’ll look into it and correct the docs.

Let me know if updating the permissions doesn’t solve the issue (looks like it’s only required on the first deploy to ssh).


Hi, just noting that since version 3.11.8 we build the Calamari tar bundle the in the Octopus home folder (usually C:\Octopus), where the server requires write permissions. So this issue no longer occurs.


Thanks! I have changed the permissions, ran the job, changed the permission back and now the Calamari tar.gz file is present . I get the mono error instead but now I can get forrward.

Again thank you for your help.