Build failing at Octo push package in vsts


(mohammed rizwan) #1

Hi,
I’m trying to push a package to octopus server and I encounter this below error.

" Error: write EPROTO 101057795:error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied:openssl\ssl\s23_clnt.c:769:
Failed to push package. write EPROTO 101057795:error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied:openssl\ssl\s23_clnt.c:769:"\

Steps:

  1. I have simple MVC web application on TFS server (TFS sitting on network 1)
  2. Building the application via VSTS build options ( successful)
  3. Creating a Nuget Package using Octo Pack and saving it to artifact location (Successful)
  4. Pushing this package to Octopus server (Octopus server is on a Azure VM) (Failed with above error)

ps: I was able to access the octopus server dashboard from my network 1


(Matthew Casperson) #2

Hi @rizwans, thanks for reaching out.

I’ll need to get some more information to help identify the root cause of the issue.

  • In step 4 you say that you are pushing the package to the Octopus server. Is this done via the Octopus TFS plugin (which calls the Octo.exe cli tool), or with another tool like Octopack (which uploads packages via the nuget tool)? If you could supply a screenshot of the TFS build process that would be helpful.
  • Can you push a package to the Octopus server from another PC using the Octo cli tools? You can find more information about pushing packages with the documentation at https://octopus.com/docs/api-and-integration/octo.exe-command-line/push.
  • Is the Octopus server configured with HTTPS?
  • Are there any proxies or other network devices between the TFS server and the Octopus server?

Regards
Matt C


(mohammed rizwan) #3

Hi @Matthew_Casperson

  1. I am using “push package(s) to octopus” extension in the VSTS to push the package from local to octopus server on Azure VM.
  2. I didn’t try Octopus CLI. I will play around with that today.
  3. No, The Octopus server is configured to be HTTP. ( I am able to access the Octopus server(which is on Azure vm) dashboard from my local network )
  4. Not really sure about the proxies. But I am sure should not be a problem.

Additionally, I tried installing octopus server on local machine i.e. the VSTS and Octopus are on same network and it still fails to push the package to octopus at step 4( using push packages to octopus).

Please help.


(Matthew Casperson) #4

Hi @rizwans,

The error SSL23_GET_SERVER_HELLO would seem to indicate that the extension is trying to make a secure connection via HTTPS, but your server is only exposed via HTTP.

Can you click the Manage link next to the Octopus Deploy Server option and paste in the screenshot of the connection details. E.g. like the screenshot below.

image

Can you also try adding the Octopus tools installer step before the Push Package to Octopus step. The tools installer will gracefully fall back to using an embedded copy of the Octopus CLI if the attempt to automatically download it fails, which removes one other possible point of failure.

Regards
Matt C


(mohammed rizwan) #5

octoconfig

Hi @Matthew_Casperson Please find the above screenshot.


(Matthew Casperson) #6

Thanks for that @rizwans. Does adding the Octopus tools installer step have any effect on the deployment?


(mohammed rizwan) #7

Thanks that helped and it worked like a charm.


(mohammed rizwan) #9

Hi @Matthew_Casperson

I am able to push the package to the octopus server, but now I am trying to create a release from vsts and is failing. Can you please help.

attached the screenshots FYI.
I have a step added in the project (myOctoDemo) on the octopus server.

projects


(Matthew Casperson) #10

Hi @rizwans , that issue looks like the drop down list didn’t populate the project ID correctly. Can you click the View YAML button and see what value is assigned to the Project Name field.

You should see something like this. If you can paste in what you see that would be useful.

If the Project Name is not in the format Project-###, try using the refresh button (the circular arrow) next to the Project Name field. This will get a fresh list of projects from the server.

Regards
Matt C


(mohammed rizwan) #11

@Matthew_Casperson Afraid to tell that I am not able to see any view yaml link on my vsts

Also, Did the refresh and I see the same projects that I have added in octopus server.


(Matthew Casperson) #12

Hi @rizwans,

The error message in that screenshot is incorrect because of a bug. I’ve created a task to fix that message, and we’ll release a new version of the plugin. I’ll let you know when the new version has been released.

In the mean time you can try falling back to version 2 of the plugin (using the Version drop down list at the top of the step) and see if that resolves the issue for you.

Regards
Matt C


(mohammed rizwan) #13

@Matthew_Casperson This is really insane I can only pick one version from the drop down. Can I just manually enter version 2 or is there any other way I can fall back to ver 2


(Matthew Casperson) #14

Hi @rizwans,

My apologies. TFS servers that have upgraded for version 2 to 3 of the plugin can still use version 2, but I see that is not the case here.

We have released version 3.0.194 of the TFS plugin, which fixes up the way the previous error was reported. Unfortunately this won’t resolve your issue, but the new error log will show us some more information. Are you able to update to the latest version, run the create release step again, and paste in a copy of the log screenshot like before. In particular the error Could not resolve project name given id is what we are looking for in the logs.

Regards
Matt C


(mohammed rizwan) #15

@Matthew_Casperson I am not able to update to latest version either. But guess what I have found a workaround for this. Instead of selecting the project name from the drop down, I manually entered the name and it worked. :slight_smile:


(Matthew Casperson) #16

Hi @rizwans, thanks for letting us know. That is a handy work around others may benefit from as well.

Regards
Matt C


(mohammed rizwan) #17

@Matthew_Casperson I will keep this forum open for now, As I am trying different things and If I encounter any issues will buzz you.


(system) #19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.