Bug report: Selecting azure web app, when there are no apps available throws an error

In the “Deploy an Azure Web App” step you can select Azure account, and then get a list of available web apps. If there are no apps available for that subscription Octopus throws an error: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host

Hi Erik,

Thanks for reaching out! I just tried this In Octopus 3.17.0 and I did not get an error (see attached GIF). Also went through our Issues backlog and didn’t see us fixing anything similar.

Which version of Octopus are you running? Wondering if its an old version that has a (now) old version of the Azure library that’s not compatible with the way Azure currently works.


Hi. We’re using 3.15.0, so not that old…
I haven’t tried to reproduce it, but I got the error multiple times, and only for that Account/subscription. The Azure subscription was completely empty (brand new), no resource groups, no apps, nothing. When I added a resource group + web app + SQL server, it started to work.

Hope that helps.

Hi Erik,

Can you try to reproduce it and send us a screenshot of the error? That’ll help us a lot with the troubleshooting


If you can pick up any javascript errors in the development console of your browser during the error, that’ll be the best.

Sorry, Dalmiro. I’m not able to reproduce it. I deleted everything on that Azure subscription, but now it works as expected. I don’t have any more brand new Azure subscriptions to test with, that’s the only difference to my current test.

Hi Erik,

I brought this discussion to the team and no one ever heard of something similar before. We’ll leave this conversation as Public in case anyone else runs into a similar issue and wants to share their repro steps.

Best regards,