Broken octopus portal UI

After upgrading octopus to v1.1.1.1404 (I think…) we have broken octopus portal UI layout, like we cannot re-order steps, it could not open a “pop up” form, like if we want to edit something, for example edit environment and much more problems with the layout where it is somehow dynamic. We have 4 machines with exactly the same configuration, OS, browsers etc. One is working fine, while others have the same issues.

When trying to hit something that activates a “pop up” form or steps reordering, firebug console points at jquery problem, so we have found that jquery source is different on machine which works fine. This could point to cache or any other temp content, so we have cleaned up all temporary internet content, browsers cache, IIS cache… Unfortunately no positive results…

Any other ideas where octopus portal jquery files could be cached?

We have also tried fresh reinstall of octopus and we are updating it with every new release.

Finally solved, by deleting old js files, those for some reason were not deleted during update or fresh reinstall. The list is attached.