Bindings issue


(Siddhartha Ghanta) #1

I’m getting below error when I configured bindings with https.
Below is the step of configuration of binding in https and error attached.
Please tell me how to resolve this.
image
image


(Kenneth Bates) #3

Hi Siddhartha,

Thanks for getting in touch! I’m sorry to hear you’re hitting this issue. I’m unable to determine the exact cause as everything seems to be configured correctly. Is the variable you have bound to the Port field (#{umbracoPort1}) resolving correctly? You can troubleshoot that by enabling two debugging variables, creating a new release and deploying it as outlined in the doc page linked below. The resulting log will show every variable before and after evaluation, and you can attach that here if needed to help us troubleshoot the issue. :slight_smile:

I hope this helps and I look forward to hearing back!

Best regards,

Kenny


(Siddhartha Ghanta) #4

https://drive.google.com/file/d/0B5mUec6mc7iNMzI2Z3BNdHZlVDBGNk03Q0ZVcFkzVUpVa1BR/view?usp=sharing
This is google drive link which has the logs zipped in it, please have a look and come back with an answer


(Kenneth Bates) #5

Hi Siddhartha,

Thanks for following up and providing those logs. I’m still looking through them, however I don’t see any any fields bound to the variable umbracoPort1, but instead I only see umbracoPort. I see both variables defined, where umbracoPort1 has a value of 19099 and umbracoPort has a value of 9099. Is it possible that you’ve recently bound this Port field to #{umbracoPort1}, but you haven’t created a new release to apply this change?

Also, what’s the name of the step that has this configuration and causing this issue?

Best regards,

Kenny


(Siddhartha Ghanta) #6

Hi Kenneth,

Yes i have bounded umbracoPort1 recently , After configuring it i have created new release even though i am getting same error .
I am using “Deploy to iis” For creating a website with various requirements Including bindings.
If i remove https from bindings, i am able to browse http.
And i have added manually https in bindings with port 19099. And its working i want this to happen through octopus. Please suggest.

Below is the screen shots.


(Kenneth Bates) #7

Hi Siddhartha,

Thanks for following up and providing that additional information. Your log is reporting only the single http binding for this step, in this line: [Octopus.Action[Site Content].IISWebSite.Bindings] = '[{"protocol":"http","port":"#{umbracoPort}","host":"","thumbprint":null,"certificateVariable":null,"requireSni":false,"enabled":true}]'

Whereas multiple bindings should be listed in this log line when you have multiple configured like this. I suspect the binding may be disabled, causing the binding to not be added via the Binding status field in the step. Could you confirm if this is perhaps the case in your scenario? It should look like the following screenshot.

I look forward to hearing back!

Best regards,

Kenny


(Siddhartha Ghanta) #8

Hi Keneth,

Please Find the below link for logs.
I have followed the steps which u mentioned.
please find the attchached screen shots , i am still getting the binding error

https://drive.google.com/file/d/0B5mUec6mc7iNeUh2OGZGR0ZvOU1XekVBOVBWX2t4VFRyZ2tJ/view?usp=sharing
image


image