Beta 2 proxy settings ignored by octopus


(daytona650) #1

Hi,

There seems to be an issue with the beta2 proxy settings. In the proxy settings in octopus manager when I select to use a custom proxy server and not browser settings any ip and port entered are either not detected or ignored by octopus. When I do this with beta1 it works fine.

Cheers
Dave


(Michael Noonan) #2

Hi Dave,

Thanks for getting in touch. I’m really sorry, I wasn’t able to reproduce the behaviour you described.

I tested setting up Octopus Server to use a custom proxy configuration by way of the Octopus Server Manager, which ran the correct configuration commands, and these proxy settings were used by Octopus Server when starting up.

Could I confirm a few things with you?

  1. Are you talking about the Octopus Server proxy settings, or are you trying to help Octopus connect to Tentacle’s via a proxy? This configuration instructs Octopus how to connect to external web sites.
  2. If this is the Octopus Server, can you confirm whether the {YourOctopusServerRoot}\Server.config file contains the Proxy settings you expected? Mine looked like this:
  <set key="Octopus.Proxy.ProxyHost">localhost</set>
  <set key="Octopus.Proxy.ProxyPassword">AQAAANCMnd8BFdERjHoAwE/Cl+sBAAAAB9HbD8Az30eCO0aYrgJkxgQAAAACAAAAAAAQZgAAAAEAACAAAACCBhdT1YhZbn6zHDZAsyon/6mc4WqGgRopjw+fdTU/fgAAAAAOgAAAAAIAACAAAAAwig1ALkBcJDK1dfraWSqHRz3XKCViDE3i1dFvSvdrCBAAAAAL7TWKWA8a6OeKknC+LhP2QAAAADsDhC0oMN9yHh0fMLQPlXM6LnVxMy4AVBrX1A45VWd/77HitRFpn2IyXjt+OI53QfdTseuQPBxwmWYXuwMPzVY=</set>
  <set key="Octopus.Proxy.ProxyPort">8080</set>
  <set key="Octopus.Proxy.ProxyUsername">ProxyUsername</set>
  <set key="Octopus.Proxy.UseDefaultProxy">false</set>

If this all looks fine, could you please send me the steps you’d use to reproduce the behaviour, and any screenshots or logs that will help me diagnose what is going wrong?

Thanks so much for taking the time to report this problem - I’m sure we’ll get to the bottom of it!

Hope that helps!
Mike


(daytona650) #3

Hi Michael,

Unfortunately we have since torn down the environment and put in version 3.3.24 to work with.

The proxy settings were those on the octopus server. Under “Other tasks”, “change proxy server settings” . On beta2 I did notice that when use a proxy server was selected and applied it did still show “Octopus is not using a proxy server” on the octopus manager front screen. I don’t recall if that was the same in beta1 sorry.

Ill have another go with it when we next rebuild the environment to beta2 and get the rest of the info.

Cheers
Dave


(Michael Noonan) #4

Hi Dave,

I’ve done some more testing and it looks like there is a display binding bug in the Octopus Manager, but the settings seem to be correctly used by Octopus Server itself.

We will fix the display bug and retest everything before we ship Octopus 3.4.0.

Thanks again for reporting this problem!
Mike


(system) closed #6