Backup and/or Restore do not work in Version 2.4.7 +

We generated a backup file from our current instance and tried to restore the backup to new instance running the same version of OD. Upon doing this only 8 projects loaded and we kept getting an error on the dashboard and could not do anything. We tried with 2.4.7 and 2.4.8 and both could not restore a backup

Hi Brent,

Sorry you are having this issue!
Could you please provide us with the error you are seeing or a screenshot?
This might help us narrow down the issue.


The error code that we encountered was the following when we tried to load various pages such as project pages, and the dashboard.

could not read value HasPendingInterruptions

When we looked in the raven db we saw that only 8 of our projects loaded. I am not sure what more information is needed but if need be we can set up a skype session to go over this more, because this is concerning for us.

Hi Brent,

Thanks for the update. I’ve created a new build that reverts back to the way we did backup/restore prior to 2.4.7. Can you try this build:

Octopus server:

You’ll need to upgrade the old Octopus server, then take a new backup, then restore it on the new server.



Sorry for the late response as I have been out of the office. We ended up migrating the server already by simply turning off the machine, copying over the raven db database, and using the original server config file. That worked, however this means we no longer have two servers to test on. I will try this on the new server in the next week and see if I can restore the new server to the old server.