Azure Linux Web App 405 error

(stormrider01) #1

I’m having what appears to be the same issue here: https://help.octopus.com/t/unable-to-deploy-to-azure-linux-web-app-using-step-deploy-an-azure-web-app/21814

Microsoft.Web.Deployment.DeploymentDetailedException: Could not connect to the remote computer ("******.scm.azurewebsites.net") using the specified process (“Web Management Service”) because the server did not respond. Make sure that the process (“Web Management Service”) is started on the remote computer. Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_COULD_NOT_CONNECT_TO_REMOTESVC. —> System.Net.WebException: The remote server returned an error: (405) Method Not Allowed.

I see 5012 is closed as completed, and I’ve added WEBSITE_DEPLOY_USE_SCM = false to the application settings in azure. I can successfully deploy the package to a windows web app in the same resource group, and I’m deploying code, not a docker image.
The Deploy to Azure step has Legacy Mode enabled, and I’m running v2019.3.0 LTS.

What am I missing here?

(Shannon Lewis) #3

Hi,

Thanks for getting in touch. Could I just double check the variable name you used in Azure? I believe it should be WEBSITE_WEBDEPLOY_USE_SCM, so just want to check in case there’s a typo.

Regards
Shannon

(stormrider01) #4

That’s it, I’m not sure where I got WEBSITE_DEPLOY_USE_SCM from, WEBSITE_WEBDEPLOY_USE_SCM does work, thanks.