Azure JSON Template functionality not working

So I have tried adding a new Azure Resource Group step for my deployment and when I paste the JSON resource manager template nothing happens. As in nothing gets parsed for parameters/variables.
The template works just fine being deployed from Visual Studio and I have even tried adding in templates from the Azure gallery to rule out my template being the issue and still nothing. How about the .parameters.json file? Where does that go?

I am on Octopus 3.7.10

Hi Silviu, thanks for getting in touch.

That sounds quite strange. Would it be possible to provide us with the ARM template so we can reproduce this on our end? It sounds like this is happening potentially for other templates as well? Is that correct?

In regards to your question about the parameters file; if the template will be provided as part of a package, then the parameters.json file would be alongside the template and supports variable substitution. The parameters are parsed directly from the template if you provide the template inline and no parameters.json file is required. We also have some documentation covering this here.

Shaun Marx