Azure DevOps Pipeline Broken

(michael) #1

As of today (around 3 hours ago) the Create Octopus Release and Deploy task from the Azure DevOps integration is no longer functional. The builds were working this morning, but now all fail with the same error saying “The Octo command line tool wasn’t found in tools directory”. The Azure DevOps extension version is 4.1.415 (latest as of Dec 19th), and the build agent versions haven’t changed either. We did find from the last successful builds that the task was using version 6.17.3 of the octopus tools and the failing builds are now using version 6.17.4 - but I can’t find any way to control what version it uses, or how that changed, we can only see that version because it’s output in the task log. This appears to be something entirely controlled by Octopus.

See attached task log for full details:
octopus log.txt (6.1 KB)

(Justin Walsh) #2

Hi @michael-void!

Thanks for reaching out - this is something that we’re currently working on a fix for, this change stems from a case change in one of our files, which causes issues on linux build agents. We’re working on getting this sorted out ASAP, but this can be worked around by creating a symlink on your build agent for Octo.dll, pointing to octo.dll.

I’ll be in touch as soon as we have some updates here, but hopefully the workaround gets your pipeline flowing once more.

(michael) #4

Thanks for the quick reply. It appears that our builds suddenly started working again (now saying they’re back to using 6.17.3).

(Elissa) #5

Do you have steps for creating a symlink on the build agent for Octo.dll

(michael) #6

Our joy was short-lived… apparently it was just some build agents that didn’t have the update yet - they are now all failing.

(michael) #7

@Justin_Walsh I’m not sure how we would go about creating a symlink to work around the issue, could you provide more detailed instruction? We’re using Azures hosted build agents, and don’t have any visibility into file the systems.

(Justin Walsh) #8

Ah, that makes it a little difficult :slight_smile:

You can make use of the Install Octopus Tools step in your build pipeline too, and then specify a version to use, instead of latest. If you specify 6.17.3 or your previous version, you should also be unstuck.

(Elissa) #9

That’s what I ended up doing and that worked.

(Elissa) #10

@Justin_Walsh did something with this change? Now we’re getting an error with the 6.17.3, it seems to be using the 6.17.4 that had been failing.

2020-02-13T06:22:33.5389480Z Looking for /opt/hostedtoolcache/octo/6.17.3/x64/*octo.dll
2020-02-13T06:22:33.5458201Z Failed to resolve Octo command line tool version 6.17.3. Using the embedded version. Error: The Octo command line tool wasn’t found in tools directory
2020-02-13T06:22:33.5552356Z Using the embedded Octo command line tool (version 6.17.4).

This full log is from the Install Octopus Tools step:
build log.txt (5.1 KB)

(Justin Walsh) #11

Hi @elissa and @michael-void

Just a quick note to let you know we’ve rolled back this change, so the latest release (6.17.6) will work as the previous one did. I apologize for the inconvenience caused by this!

1 Like
(michael) #12

@Justin_Walsh thanks for the update. It would still be nice to know why explicitly setting the tools version doesn’t work (see @elissa’s post), we would like to have better visibility/control over version upgrades.

(Justin Walsh) #13

We updated the extension to attempt to fix it, but we found another issue with a case-sensitive element in one of the later steps, which explains the issue @Elissa was seeing - I believe everything should be back up and running with .6 now though. I’ll double-check with the responsible team to make sure, and get back to you ASAP.

Best,