Automatic backups not running since last backup fail (V2.6.5)

Hi. The hard drive where we stored the backups ran out of a space a little while back, causing a backup to fail. Since then Automatic backups are not running. I suspect it’s something to do with a Failed “Scheduled Database Backup” still showing in the Active Tasks view. We’ve tried a restart of the service but it’s not affected anything. Is there any way we can remove the task from Active and get the backups running again?

I’ve attached a screenshot showing the backup task stuck in Active.


Hi Daniel,

Thanks for reaching out. Could you check that the task actually shows up as “Failed” on the database? Paul’s steps on this comment show how to check this

Could you also try forcing a manual deployment from Configuration -> Backup and let us know if (1) It completes successfully and (2) If after that, scheduled deployments start to run again.



Thanks. Yes a tried a manual backup. I also clicked on “Try Again” on the failed backup. Both backups worked but the task is still stuck there in active. I got the document from RavenDB. State is “Failed”

{ "Name": "Backup", "Arguments": {}, "Description": "Scheduled database backup", "QueueTime": "2015-09-26T15:01:32.6085251+00:00", "QueueTimeExpiry": "01:30:00", "StartTime": "2015-09-26T15:01:32.7957215+00:00", "LastUpdatedTime": "2015-09-26T15:10:28.7702141+00:00", "CompletedTime": "2015-09-26T15:10:28.7702141+00:00", "ErrorMessage": "", "ConcurrencyTag": null, "State": "Failed", "ActorId": "TaskController-B+m6-AnBz35hDmQ@SQ-PLLWINCSAPP002-062684EA", "HasPendingInterruptions": false, "HasWarningsOrErrors": true, "ProjectId": null, "EnvironmentId": null, "ExtendedViewLogPermissions": [], "ExtendedCreatePermissions": [], "CanRerun": true }

Hi. Any ideas? Still no automatic backups. Would it help if I changed the status in the document? What is it that makes it sit in the active queue?

Hi Daniel,

Its possible that corrupt indexes are behind this. Please follow the instructions on this link to repair the database and let me know if backups start working after that



Thanks Dalmiro. Would this impact performance or affect usage in any way? Or will this have to be an out of hours action?

Hi Daniel,

It shouldn’t take too long or impact your performance (at least not in a bad way). It will require a restart of the Octopus service though, so you might wanna do it out of hours if you have many users depending o the service.

Let me know how it goes

Thanks! That seems to have done the trick. Scheduled backups are running again after the repair.