Auto-deploy trigger only attempted to re-queue twice?

We recently created a trigger for Octopus (version 3.15.4) to automatically deploy to deployment targets with a specified role to:
Automatically deploy when Machine enabled Machine found healthy for the roles

This has worked well for us in many cases, but the other day it failed to deploy and when I looked at the machine event logs it said:
Auto-deploy trigger is blocked from deploying for release to : Attempted to re-queue the deployment Deploy to Prod but it is in the state Executing

It tried this twice, then stopped attempting to re-queue the deployment.

Is there a limit to how many attempts it will make to re-queue?
If so, can that be modified somewhere?
What else would cause it to stop attempting to re-queue?

Thank you for any help you can provide.

Has anyone else run into this problem? It randomly happened again this morning.

Hi @dandrews-dk,

Thanks for getting in touch! I’m very sorry for the delay in getting back to you here. I think the first step here would be to attach a copy of your deployment logs where you are running into this issue.

This will provide us with some more contextual information about the deployment and what could be causing this to happen.

The following documentation page has instructions on downloading the raw log file, can you please attach the file to your response.

Looking forward to hearing from you and getting to the bottom of this.

Best regards,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.