Assistance with Azure Tools migration

Hello,

I’ve just noticed the warning that is now being shown when we do a deployment that involves a “Deploy to Azure” step. The details on the help page that it links to is this one:

The problem for me is, I have previously configured this deploy step just using a nice preconfigured step template (the “DEPLOY AN AZURE WEB APP (WEB DEPLOY)” one), and I’m not at all sure about how I would go about replacing this with scripts to do the deployment now.

I also see that I’m getting the same warning on my step where I do an alert to teams - that is just a “Run a script” step that says it is based on a community Microsoft Teams - Post a message step template.

I also note that the same step IS still available in the “Add Step” wizard, so does this mean that people configuring an Azure deployment even now will be starting with a deprecated feature?

Is there any migration documentation available to help us take this leap into the script version?

Thanks
Bron

I did some further research, and worked out that MAYBE I can actually resolve all this without writing scripts, just by moving to a dynamic worker that uses Docker, if I’ve understood correctly.

But I’ve given it a go, and am getting stuck at the point of doing the initial download of the docker image:

What I had done was create a new worker process Windows (default) and an external feed for docker, and updated the “Deploy to Azure” step as follows:

Let me know what I can provide you with to help in working out the cause of this.

Thanks!

Hi Bron,

That’s a shame that you have hit these issues but I believe we can overcome them quite quickly. Your follow-up message is correct and you are on the right path. The configuration you sent a picture through of, should work.

I have a couple of suggestions that might help . Can you firstly try to pull down the latest Worket-tools. You can replace your container image with: octopusdeploy/worker-tools

Secondly, the web app step has also been improved upon. When configuring these steps again, you should aim to use the Deploy an Azure App Service Step. There are more details about that here: Improved Azure App Service deployments - Octopus Deploy

Can you try those two changes and see if you end up in a better place. Please let me know how you get on.

Regards,

Dane

Hi Bron,

One more thing to check. Make sure your Dynamic Workers are using Windows Server Core 2019.

As you can see from that link, Server Core 2019 has the docker installation while 2016 doesn’t.

Regards,

Dane

Thanks for your help Dane. We have lift off!

First I tried changing to octopusdeploy/worker-tools rather than the more detailed version that the doco mentioned, and that didn’t help. I then changed the Dynamic Worker to use Windows Server Core 2019, rather than “Windows (default)” and with that change, it DID manage to do the docker pull. However, it actually had an error getting that new octopusdeploy/worker-tools image:

So I changed back to the docker image that I had before, which was actually populated frrom the Octopus UI:

(Aside: a bug happened where this change never “stuck” after hitting Save. I ended up having to change back to “Runs directly on a Worker”, save that, and then change it to “Runs inside a container or a worker” and set the right value, in order for the change to stick).

And that worked!
image

I’ll take the next step now, of updating to the newer step template. Thanks again!

I guess one thing that could help others is if the doco at Execution containers for workers - Octopus Deploy was updated to specifically state that the “Windows (default)” also doesn’t include docker (I assume it must be using Server 2016 still?)

Hi Bron,

That’s a good point. I will look into that today.

I am also curious as to the error you received when trying to pull down the latest. I’ll do some exploring on my end and see if I can pinpoint the problem.

What version of Octopus are you running? I would like to replicate exactly what you have.
Anyway, thank you for letting me know you got it sorted.

Regards,

Dane

Sure, it’s v2021.2 (Build 7650) - on Octopus Cloud.

Thanks,
Bron