An unexpected error occurred in Octopus v2019.3.0: "TypeError: Cannot read property 'isMultiTenancyEnabled' of null"

I’m upgrading my company’s Octopus server from 2018 LTS to 2019.3 and getting the same error as this thread, which was unfortunately closed a few days ago. I tried the same reboot that the creator mentioned, but it did not work for me. Here is the complete error message:

Octopus v2019.3.0TypeError: Cannot read property ‘isMultiTenancyEnabled’ of null

Function.C [as mapToProps] (
r (
Function.r.mapToProps (
r (
i (
undefined ( (
c.initSelector (
new c (
constructClassInstance (

I don’t know if it’s relevant or not, but we are using tenants for some of our deploy processes.

I managed to pull logs from the browser’s javascript console (OctopusJSConsole.txt (4.3 KB)) before we reverted our server back to what it was before. If I’m reading it correctly it looks like I was able to authenticate with the server (ours is through Active Directory) but it couldn’t pull permissions for my user. I didn’t find any logs on the server itself, but we’re giving it another crack today so I’ll be able to take another look.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.