After deleting Tenant Tags, Runbook is Corrupted

When I click on the Process tab for my runbook, this is what loads:

The last thing I did was delete a Tenant tag set. But it made me remove all uses of the tag set before it let me delete it, so I don’t know why it would error out like this.

I have a lot of configuration and custom code in this runbook that I would rather not try to recreate.

How can I recover this runbook?

Hi @OctopusSchaff,

Thank you for contacting Octopus Support. I’m sorry you are running into this issue with your Runbook after removing Tenant Tags.

Before we dive deeper, can you confirm that caching isn’t at play here by trying to open this Runbook in a private/incognito tab?

Let me know if the error still shows up.

Regards,
Donny

I tried it in an incognito tab, but it still showed the error.

However, I had a copy of the Runbook in another project. I manually re-created the runbook from the copy and it is working fine now.

I will probably not delete a Tennent Tag group again. The risk is too great. I will just leave them to collect dust.

Hi @OctopusSchaff,

Thank you for getting back to me. I’m glad to hear you had a copy of the Runbook.

However, it is certainly not intended behavior to break the Runbook when deleting a Tenant Tag set. I would like to reproduce this issue in a test environment. Would you be willing to share a copy of the Process JSON for the Runbook and let me know what version of Octopus Server you are running?

You may upload a copy of the Process JSON via the secure link here:

I look forward to hearing back from you.

Regards,
Donny

I would be happy to send you the JSON of the process step.

Unfortunately, I cannot get to the screen to download the json of the Process page. I get the error I reported when I click on the Process tab. The Process tab never loads.

I am running version 2021.1.7316 of Octopus Deploy.

Hi @OctopusSchaff,

Thank you for the quick response.

I have something to try to get the JSON. Navigate to the Project, then Runbooks. Right-click on the broken Runbook and “Copy Link Address”.

Example: http://octopusserver/app#/Spaces-1/projects/test/operations/runbooks/Runbooks-121

Remove everything between the SpaceId and /runbooks/ and change app# to api

Example: http://octopusserver/api/Spaces-1/runbooks/Runbooks-121

Use that link to generate this page and copy the “RunbookProcess” link:

Then paste that with your Octopus Server URL to (hopefully) generate the Process JSON:

If that URL does not work, showing the same issue. Could you try sharing an export of the entire Project instead?

Let me know if either of those options work.

Regards,
Donny

Thank worked. I will upload the json shortly.

Hi @OctopusSchaff,

Thank you for sharing that.

I’m working on attempting to reproduce this issue now.

As soon as I know more I’ll let you know.

Regards,
Donny

Hi @OctopusSchaff,

Thank you kindly for your report of this bug, and my sincere apologies for the confusion and inconvenience we caused with it. Great to hear you had a copy of this to pick up from. I’ve been able to reproduce this issue, and raised it as a bug report at the following link.

Please let us know if you have any questions or concerns going forward!

Best regards,

Kenny

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.