Add environment button does nothing

Finally got Octopus installed and set up, and now I can’t seem to do anything with the website.

From a new install the Add environment button does not perform any action. I’ve tried Chrome and IE with no luck.

The Octopus install I have is 0.8.414.2052.


Sorry for this issue, I’ll look into it tonight.

In Chrome, if you bring up developer tools (Ctrl+Shift+i) and go to the “Network” tab or “Console” tab, and reload the page and click the button, do you see any errors? I’m wondering if there is a problem with the JavaScript not loading.


The network tab shows 200s for all the items.

The console gives the warning “Resource interepreted as Stylesheet/Script/Image but transferred with MIME type text/plain.” for every file (all the css, scripts and image). There were no errors.

Forgot to mention this is on Windows 2008 R2.


Ok, I found the problem.

Turns out my IIS install didn’t have the static content feature turned on, so the scripts and css files were not loading properly. Installing this feature fixed the problem.

Might be worth adding a check for this in the installer or something. Thanks.

Ok, I found the issue.

The js and css files were not being served correctly because IIS 7 was not configured to serve static content.

Adding this feature fixed the issue.

Might be worth adding a check for this in the installer.

Gah! I’ve tried posting this 3 times now!

I fixed the issue. IIS was not set up to serve static content, so the css and scripts were not loading properly, but also not returning an error result (4xx).

Maybe catching this in the installer would help, otherwise just mentioning it in the doco or faq or something.


I’m having the same problem with version 0.9.511.2528.

Hi Jimit,

Did the same fix described above (configuring IIS to serve static content) solve the problem?