504 Gateway Time-out on getting all variables

(Tonybest) #1

Open Chrome and GET: http://octopus_server/api/Spaces-2/variables/all
After about 60 seconds, showing: 504 Gateway Time-out

Using python-requests command has the same issue:
get: http://octopus_server/api/Spaces-2/variables/all
response status code: 504

All other GET like http://octopus_server/api/Spaces-2/tenantvariables/all are working fine.

#4

Hi Tony,

Sorry this one got missed.

At fist glance there appears to be something else closing the connection, as 20 seconds is very aggressive and we wouldn’t (or shouldn’t) time out that early.

The GET command you are running would be quite computationally expensive, however it should return a result. Are you able to let me know if anything changed that started causing this issue, especially if you have just upgraded your Octopus Server (original and upgrade versions would be greatly appreciated if this was the case).

One option that may help work around the problem would be to only grab a certain subset of variables and then iterate over than number to make sure you get all the variables. For example:

http://octopus_server/api/Spaces-2/variables/all?skip=0&take=1000

Hopefully that helps relieve the immediate problems until we can identify the root cause.

Regards,
Alex

(Tonybest) #6

I tried a few options:
http://octopus_server/api/Spaces-2/variables/all?skip=0&take=1

http://octopus_server/api/Spaces-2/variables/all?skip=0&take=1000

I timed and found out “504 Gateway Time-out” always came out after about 60 seconds. Somewhere seems to have a timeout setting at 60 seconds.

I searched for 504 and found out:
The 504 Gateway Timeout error is an HTTP status code that means that one server did not receive a timely response from another server that it was accessing while attempting to load the web page or fill another request by the browser

About versions:
Initial version v2019.10.4
Current version v2019.11.1

(Tonybest) #7

Today the error message turns from:
“504 Gateway Time-out”
to:
{
“ErrorMessage”: “The resource ‘RunbookRuns-101’ was not found.”
}

Any other users have the similar issue?

#8

Hi Tony,

That sounds like a different issue. Are you able to connect via a new email to support@octopus.com as I suspect we will need to ask for logs and other non-public information.

Regards
Alex

(Tonybest) #9

got the answer: https://github.com/OctopusDeploy/Issues/issues/6143
we need to upgrade the Octopus server version