404 Error on Azure Web App Deploy

I was curious if there is a way to change the test destination or what determines the test location?

I noticed post deploy it runs a check against, #{myapp}.scm.azurewebsites.net" which doesnt actually exist, however
#{myapp}.scm.azurewebsites.net does exist and did successfully deploy. can I do something for this?


Thanks for reaching out! Can you expand upon your scenario and what you’re trying to achieve? That will help us better understand your situation and find what’s going on.

  • Can you confirm what you mean by “test destination”?
  • Do you have a post deploy script as part of your package, or a custom post-deployment script in your step, that is doing something? If so, can you provide a screenshot of the whole step?
  • Can you provide a full verbose deployment log? Refer to the following documentation which details two debugging variables to turn on, create and deploy a new release, and download the raw log: https://octopus.com/docs/how-to/how-to-turn-on-variable-logging-and-export-the-task-log
  • Can you also attach a screenshot of your entire deployment process?

I look forward to hearing back!

Kind regards,


So I think it was me being ignorant on the test address haha, I ran a redeploy and changed my arm templates up a bit and I think Octopus was doing what it was supposed to my and stuff did legitimately fail