3.5.1 Upgrade - SMTP Errors

After upgrading to Octopus 3.5.1 I started receiving SMTP errors that were previously working in version 3.4.x.

My SMTP configuration is setup for Office 365 and was previously working (nothing has changed except for the server upgrade).

The specific error I’m receiving is the following:
The step failed: Activity Email Confirmation on the Octopus Server failed with error 'The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM'.

Has anyone else experienced this issue? Is there a way to rollback to 3.4.x?

Hi Matt,

Thanks for getting in touch.

Unfortunately we were unable to reproduce this issue and could find no code-changes in version 3.5.* regarding the email handling within Octopus. Those error messages re. “5.7.57 SMTP” are returned from Office365.

To confirm if this is related to Octopus or the Office365 SMTP settings, are you able to temporarily setup an alternative SMTP provider and test if Octopus is delivering test emails? (see the Configuration > SMTP screen).

You could use mailtrap.io as a free tool to send test emails and see if they come through from Octopus.

Let me know how you go.


Hi Mark,

Thanks for the response. I have tested on mailtrap.io and confirmed that SMTP does work. So this appears to be an Office 365 issue. I’ll follow-up on this thread with my findings once it’s resolved, just in case this can help others that hit this error with O365.


Following up here…we finally tracked down the issue with the Office 365 account (again, not an issue with Octopus…but posting here just to help others):

  • The account that was being used recently had the password changed to a longer password. Apparently Office365 limits (truncates) the password to only 16 characters. There is no error when changing an account password to something longer than 16 characters, the system just truncates it and shows success. Once we reset the password to a shorter length, everything worked fine.